Сдай ЕГЭ на 100 баллов!

Учебные материалы и курсы для подготовки к ЕГЭ по математике и другим предметам

+7 (495) 984-09-27
+7 (800) 775-06-82
Ваш регион: Москва

Задача №7. Электронные таблицы. Абсолютная и относительная адресация. Графики и диаграммы.

Автор материалов — Лада Борисовна Есакова.

Microsoft Excel (в дальнейшем просто — Excel) — это программа выполнения расчетов и управления так называемыми электронными таблицами.

Excel позволяет выполнять сложные расчеты, в которых могут использоваться данные, расположенные в разных областях электронной таблицы и связанные между собой определенной зависимостью. Для выполнения таких расчетов в Excel существует возможность вводить различные формулы в ячейки таблицы. Excel выполняет вычисления и отображает результат в ячейке с формулой.

Важной особенностью использования электронной таблицы является автоматический пересчет результатов при изменении значений ячеек. Excel также может строить и обновлять графики, основанные на введенных числах.

Адрес ячейки в электронных таблицах состоит из имени столбца и следующего за ним номера строки, например, C15.

Для написания формул используют адреса ячеек и знаки арифметических операций (+, -, *, /, ^). Формула начинается знаком =.

В Excel предусмотрены стандартные функции, которые могут быть использованы в формулах. Это математические, логические, текстовые, финансовые и другие функции. Однако, на экзамене Вам могут встретиться только самые простые функции: СЧЕТ (количество непустых ячеек), СУММ (сумма), СРЗНАЧ (среднее значение), МИН (минимальное значение), МАКС (максимальное значение).

Диапазон ячеек обозначается следующим образом: A1:D4 (все ячейки прямоугольника от A1 до D4.

h

Адреса ячеек бывают относительными, абсолютными и смешанными.

Они по-разному ведут себя при копировании формулы из ячейки в ячейку.

Относительная адресация:

Если в ячейке B2 мы напишем формулу =D1+3, то таблица воспримет это как «взять значение ячейки на две правее и на одну выше текущей, и прибавить к нему 3».

kl

Т.е. адрес D1 воспринимается таблицей, как положение относительно ячейки, куда вводится формула. Такой адрес называется относительным. При копировании такой формулы в другую ячейку, таблица автоматически пересчитает адрес относительно нового расположения формулы:

kl

Абсолютная адресация:

Если нам не нужно, чтобы адрес пересчитывался при копировании формулы, мы можем его «закрепить» в формуле — поставить знак $ перед буквой и индексом ячейки: =$D$1+3. Такой адрес называется абсолютным. Такая формула не будет изменяться при копировании:

Смешанная адресация:

Если же мы хотим, чтобы при копировании формулы автоматически пересчитывался, к примеру, только индекс ячейки, а буква оставалась неизменной, мы можем «закрепить» в формуле только букву (или наоборот):  =$D1+3. Такой адрес называется смешанным. При копировании формулы будет меняться только индекс в адресе ячейки:

Электронные таблицы. Копирование формул.

Пример 1.

В ячейке C2 записана формула =$E$3+D2. Какой вид приобретет формула, после того как ячейку C2 скопируют в ячейку B1?

1) =$E$3+C1   2) =$D$3+D2      3) =$E$3+E3      4) =$F$4+D2

Решение:

Место расположения формулы меняется с C2 на B1, т.е. формула сдвигается на одну ячейку влево и на одну ячейку вверх (буква «уменьшается» на единицу и индекс уменьшается на единицу). Значит, так же изменятся все относительные адреса, а абсолютные (закрепленные знаком $) останутся неизменными:

=$E$3+С1.

Ответ: 1

Пример 2.

В ячейке В11 электронной таблицы записана формула. Эту формулу скопировали в ячейку А10. В результате значение в ячейке А10 вычисляется по формуле х—Зу, где х — значение в ячейке С22, а у — значение в ячейке D22. Укажите, какая формула могла быть написана в ячейке В11.

1) =C22-3*D22          2) =D$22-3*$D23      3) =C$22-3*D$22      4) =$C22-3*$D22

Решение:

Проанализируем поочередно каждую формулу:

Место расположения формулы меняется с B11 на A10, т.е. буква «уменьшается» на 1 и индекс уменьшается на 1.

Тогда при копировании формулы изменятся следующим образом:

1)      =B21-3*C21

2)      =C$22-3*$D22

3)      =B$22-3*C$22

4)      =$C21-3*$D21

Условию задачи соответствует формула 2).

Ответ: 2

 

Электронные таблицы. Определение значения формулы.

Пример 3.

Дан фрагмент электронной таблицы:

А

В

С

D

1

1

2

3

2

4

5

6

3

7

8

9

В ячейку D1 введена формула =$А$1*В1+С2, а затем скопирована в ячейку D2. Какое значение в результате появится в ячейке D2?

1) 10   2) 14    3) 16    4) 24

Решение:

Место расположения формулы меняется с D1 на D2, т.е. буква не меняется, а индекс увеличивается на 1.

Значит, формула примет вид: =$А$1*В2+С3. Подставим в формулу числовые значения ячеек:1*5+9=14. Правильный ответ указан под номером 2.

Ответ: 2

Пример 4.

В электронной таблице значение формулы =СРЗНАЧ(A6:C6) равно (-2). Чему равно значение формулы =СУММ(A6:D6), если значение ячейки D6 равно 5?

1) 1                    2) -1                     3) -3                     4) 7

Решение:

 

По определению среднего значения:

СРЗНАЧ(A6:C6) = СУММ(A6:С6)/3 = -2

Значит, СУММ(A6:С6) = -6

СУММ(A6:D6) = СУММ(A6:С6)+D6 = -6+5 = -1

Ответ: 2

 

Электронные таблицы и диаграммы.

Пример 5.

Дан фрагмент электронной таблицы в режиме отображения формул.

После выполнения вычислений построили диаграмму по значениям диапазона  A1:D1. Укажите полученную диаграмму:

 

Решение:

Вычислим по формулам значения ячеек A1:D1.

B1 = 3-2 =1

A1 = 2-1 =1

C1 = 1+2 =3

D1 = 1*3 =3

Этим данным соответствует диаграмма 3.

Ответ:3

Звоните нам: +7 (800) 775-06-82 (бесплатный звонок по России)
                       +7 (495) 984-09-27 (бесплатный звонок по Москве)

Или нажмите на кнопку «Узнать больше», чтобы заполнить контактную форму. Мы обязательно Вам перезвоним.