Ваш регион: Москва
ЕГЭ-пробный

Задача №8. Анализ программы с циклами.

Автор материалов - Лада Борисовна Есакова.

Для решения этой задачи нужно знать основные конструкции языка программирования:

- Объявление переменных;

- Оператор присваивания;

- Оператор вывода;

- Операторы цикла.

Кроме этого, пригодятся математические формулы:

n-го члена арифметической прогрессии ,

суммы n членов геометрической прогрессии.

Пример 1.

За­пи­ши­те число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках про­грам­ми­ро­ва­ния.

Бей­сик

Python

DIM S, N AS INTEGER

S = 47

N = 1

WHILE S > 0

S = S - 9

N = N + 4

WEND

PRINT(N)

s = 47

n = 1

while s > 0:

s = s - 9

n = n + 4

print(n)

Пас­каль

Ал­го­рит­ми­че­ский язык

var s, n: integer;

begin

s := 47;

n := 1;

while s > 0 do

begin

s := s - 9;

n := n + 4

end;

writeln(n)

end.

алг

нач

цел s, n

s := 47

n := 1

нц пока s > 0

s := s - 9

n := n + 4

кц

вывод n

кон

Си

#include <stdio.h>

void main()

{

int s, n;

s = 47;

n = 1;

while (s > 0) {

s = s – 9;

n = n + 4;

}

printf("%d\n", n);

}

Решение:

Цикл while вы­пол­ня­ет­ся до тех пор, пока ис­тин­но усло­вие s > 0, т. е. пе­ре­мен­ная s опре­де­ля­ет, сколь­ко раз вы­пол­нит­ся цикл. По­сколь­ку из­на­чаль­но s = 47, а затем уменьшается на 9, цикл вы­пол­нит­ся 6 раз, сле­до­ва­тель­но, n = 6 · 4 + 1 = 25.

 

Ответ: 25

 

Пример 2.

За­пи­ши­те число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­щей про­грам­мы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках про­грам­ми­ро­ва­ния.

Бей­сик

Python

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S < 111

S = S + 8

N = N + 2

WEND

PRINT N

s = 0

n = 0

while s < 111:

s = s + 8

n = n + 2

print(n)

Пас­каль

Ал­го­рит­ми­че­ский язык

var s, n: integer;

begin

s := 0;

n := 0;

while s < 111 do

begin

s := s + 8;

n := n + 2

end;

writeln(n)

end.

алг

нач

цел n, s

n := 0

s := 0

нц пока s < 111

s := s + 8

n := n + 2

кц

вывод n

кон

Си

#include

int main()

{ int s = 0, n = 0;

while (s < 111) { s = s + 8; n = n + 2; }

printf("%d\n", n);

return 0;

}

 

Решение:

Цикл while вы­пол­ня­ет­ся до тех пор, пока ис­тин­но усло­вие s < 111, т. е. пе­ре­мен­ная s опре­де­ля­ет, сколь­ко раз вы­пол­нит­ся цикл. По­сколь­ку из­на­чаль­но s = 0, а затем увеличивается на 8, цикл вы­пол­нит­ся 14 раз, сле­до­ва­тель­но, n = 2 * 14 = 28.

Ответ: 28

 

Пример 3.

За­пи­ши­те число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках про­грам­ми­ро­ва­ния.

 

Бей­сик

Python

DIM S, N AS INTEGER

S = 301

N = 0

WHILE S > 0

S = S - 10

N = N + 2

WEND

PRINT N

s = 301

n = 0

while s > 0:

s = s - 10

n = n + 2

print(n)

Пас­каль

Ал­го­рит­ми­че­ский язык

var s, n: integer;

begin

s := 301;

n := 0;

while s > 0 do

begin

s := s - 10;

n := n + 2

end;

writeln(n)

end.

алг

нач

цел n, s

s := 301

n := 0

нц пока s > 0

s := s - 10

n := n + 2

кц

вывод n

кон

Си

#include <stdio.h>

int main()

{

int s = 301, n = 0;

while (s > 0) {

s = s - 10;

n = n + 2;

}

printf("%d\n", n);

return 0;

}

Решение:

За­ме­тим, что после 30 ите­ра­ций цикла s = 1, а n = 60. После 31 ите­ра­ции ста­нет s = -9, n = 62, и цикл пре­кра­тит­ся.

Ответ: 62

Звоните нам: 8 (800) 775-06-82 (бесплатный звонок по России)
                       +7 (495) 984-09-27 (бесплатный звонок по Москве)

Или нажмите на кнопку «Узнать больше», чтобы заполнить контактную форму. Мы обязательно Вам перезвоним.

Полный онлайн-курс подготовки к ЕГЭ по математике. Структурировано. Четко. Без воды. Сдай ЕГЭ на 100 баллов!

Смотреть

Для нормального функционирования и Вашего удобства, сайт использует файлы cookies. Это совершенно обычная практика.Продолжая использовать портал, Вы соглашаетесь с нашей Политикой конфиденциальности.

Позвоните мне

Все поля обязательны для заполнения

Отправить