previous arrow
next arrow
Slider

Досрочный ЕГЭ 2020 года, Информатика

Задачи:

1. Сколько единиц в двоичной записи шестнадцатеричного числа E1F016?

Посмотреть ответ. Посмотреть решение.

2. Миша заполнял таблицу истинности функции (x\wedge \lnot y)\vee(x \equiv z)\vee \lnot w  но успел заполнить лишь фрагмент из трёх различных её строк, даже не указав, какому столбцу таблицы соответствует каждая из переменных w, x, y, z.

(x\wedge \lnot y)\vee(x \equiv z)\vee \lnot w
0 1 1 0 0
0 0
1 0 1 0

Определите, какому столбцу таблицы соответствует каждая из переменных w, x, y, z.

В ответе напишите буквы w, x, y, z в том порядке, в котором идут соответствующие им столбцы (сначала буква, соответствующая первому столбцу; затем буква, соответствующая второму столбцу, и т.д.). Буквы в ответе пишите подряд, никаких разделителей между буквами ставить не нужно.

Пример. Функция задана выражением \lnot x \vee y  зависящим от двух переменных, а фрагмент таблицы имеет следующий вид.

\lnot x \vee y
0 1 0

В этом случае первому столбцу соответствует переменная y, а второму столбцу – переменная x. В ответе следует написать yx.

Посмотреть ответ. Посмотреть решение.

3. На рисунке слева изображена схема дорог N-ского района. В таблице звёздочкой обозначено наличие дороги из одного населённого пункта в другой. Отсутствие звёздочки означает, что такой дороги нет.

Каждому населённому пункту на схеме соответствует его номер в таблице, но неизвестно, какой именно номер. Определите, какие номера населённых пунктов в таблице могут соответствовать населённым пунктам E и G на схеме. В ответе запишите эти два номера в возрастающем порядке без пробелов и знаков препинания.

Посмотреть ответ. Посмотреть решение.

4. Ниже представлены два фрагмента таблиц из базы данных о жителях микрорайона. Каждая строка таблицы 2 содержит информацию о ребёнке и об одном из его родителей. Информация представлена значением поля ID в соответствующей строке таблицы 1. Определите на основании приведённых данных, у скольких детей на момент их рождения матерям было меньше 27 полных лет. При вычислении ответа учитывайте только информацию из приведённых фрагментов таблиц.

Посмотреть ответ. Посмотреть решение.

5. По каналу связи передаются сообщения, содержащие только четыре буквы: А, Б, В, Г; для передачи используется двоичный код, удовлетворяющий условию Фано. Для букв Б, В, Г используются такие кодовые слова: Б – 101; В – 110; Г – 0.

Укажите кратчайшее кодовое слово для буквы А, при котором код будет допускать однозначное декодирование. Если таких кодов несколько, укажите код с наибольшим числовым значением.

Примечание. Условие Фано означает, что никакое кодовое слово не является началом другого кодового слова. Это обеспечивает возможность однозначной расшифровки закодированных сообщений.

Посмотреть ответ. Посмотреть решение.

6. На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число следующим образом.

1) Строится двоичная запись числа N.

2) К этой записи дописываются справа ещё два разряда по следующему правилу: если N чётное, в конец числа (справа) дописываются два нуля, в противном случае справа дописываются две единицы. Например, двоичная запись 1001 числа 9 будет преобразована в 100111.

Полученная таким образом запись (в ней на два разряда больше, чем в записи исходного числа N) является двоичной записью числа – результата работы данного алгоритма.

Укажите минимальное число N, для которого результат работы алгоритма будет больше 134. В ответе это число запишите в десятичной системе счисления.

Посмотреть ответ. Посмотреть решение.

7. Дан фрагмент электронной таблицы. Из ячейки A3 в ячейку C4 была скопирована формула. При копировании адреса ячеек в формуле автоматически изменились. Какова сумма числовых значений формул в ячейках A3 и C4?

Примечание. Знак $ обозначает абсолютную адресацию.

Посмотреть ответ. Посмотреть решение.

8. Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

Бейсик Python
DIM S, N AS INTEGER 
S = 175 
N = 0 WHILE S + N < 325 
  S = S - 10 
  N = N + 30 
WEND PRINT 
PRINT S
s = 175
n = 0 while s + n < 325:
    s = s - 10
    n = n + 30
print(s)
Алгоритмический язык Паскаль
алг
нач
   цел n, s
   s := 175
   n := 0
   нц пока s + n < 325
     s := s - 10
     n := n + 30
   кц
   вывод s
кон
var s, n: integer;
begin
   s := 175;
   n := 0;
   while s + n < 325 do
   begin
     s := s - 10;
     n := n + 30
   end;
   writeln(s)
end.
С++
#include <iostream>
using namespace std; 
 
int main() {
     int s = 175, n = 0;
     while (s + n < 325) {
          s = s - 10;
          n = n + 30;
      }
     cout << s << endl;
     return 0;
}

Посмотреть ответ. Посмотреть решение.

9. Музыкальный фрагмент был записан в формате квадро (четырёхканальная запись), оцифрован и сохранён в виде файла без использования сжатия данных. Размер полученного файла без учёта размера заголовка файла – 12 Мбайт. Затем тот же музыкальный фрагмент был записан повторно в формате моно и оцифрован с разрешением в 2 раза выше и частотой дискретизации в 1,5 раза меньше, чем в первый раз. Сжатие данных не производилось. Укажите размер в Мбайт файла, полученного при повторной записи. В ответе запишите только целое число, единицу измерения писать не нужно. Искомый объём не учитывает размера заголовка файла.

Посмотреть ответ. Посмотреть решение.

10. Вася составляет 5-буквенные слова, в которых есть только буквы В, О, Л, К, причём буква В используется в каждом слове ровно 1 раз. Каждая из других допустимых букв может встречаться в слове любое количество раз или не встречаться совсем. Словом считается любая допустимая последовательность букв, не обязательно осмысленная. Сколько существует таких слов, которые может написать Вася?

Посмотреть ответ. Посмотреть решение.

11. Ниже на пяти языках программирования записан рекурсивный алгоритм F.

Бейсик Python
SUB F(n)
   IF n > 0 THEN
       PRINT n,
       F(n - 3)
       F(n \ 2)
   END IF
END SUB
def F(n):
     if n > 0:
         print(n)
         F(n - 3)
         F(n // 2)
Алгоритмический язык Паскаль
алг F (цел n)
нач
    если n > 0 то
      вывод n
      F(n - 3)
      F(div(n, 2))
    все 
кон
procedure F(n: integer);
 begin   if n > 0 then
   begin
     write(n);
     F(n - 3);
     F(n div 2)
   end
end;
С++
void F(int n){
     if (n > 0){
         std::cout << n;
         F(n - 3);
         F(n / 2);
     }
}

Запишите подряд без пробелов и разделителей все числа, которые будут выведены на экран при выполнении вызова F(7). Числа должны быть записаны в том же порядке, в котором они выводятся на экран.

Посмотреть ответ. Посмотреть решение.

12. В терминологии сетей TCP/IP маской сети называется двоичное число, определяющее, какая часть IP-адреса узла сети относится к адресу сети, а какая – к адресу самого узла в этой сети. Обычно маска записывается по тем же правилам, что и IP-адрес, – в виде четырёх байтов, причём каждый байт записывается в виде десятичного числа. При этом в маске сначала (в старших разрядах) стоят единицы, а затем с некоторого разряда – нули. Адрес сети получается в результате применения поразрядной конъюнкции к заданному IP-адресу узла и маске.

Например, если IP-адрес узла равен 231.32.255.131, а маска равна 255.255.240.0, то адрес сети равен 231.32.240.0.

Для узла с IP-адресом 117.191.176.37 адрес сети равен 117.191.160.0. Чему равен третий слева байт маски? Ответ запишите в виде десятичного числа.

Посмотреть ответ. Посмотреть решение.

13. При регистрации в компьютерной системе каждому пользователю выдаётся пароль, состоящий из 25 символов и содержащий только символы из 7-символьного набора: С, Д, А, М, Е, Г, Э. В базе данных для хранения сведений о каждом пользователе отведено одинаковое и минимально возможное целое число байт. При этом используют посимвольное кодирование паролей, все символы кодируют одинаковым и минимально возможным количеством бит. Кроме собственно пароля, для каждого пользователя в системе хранятся дополнительные сведения, для чего выделено целое число байт; это число одно и то же для всех пользователей. Для хранения сведений о 50 пользователях потребовалось 1200 байт. Сколько байт выделено для хранения дополнительных сведений об одном пользователе? В ответе запишите только целое число – количество байт.

Посмотреть ответ. Посмотреть решение.

14. Исполнитель Редактор получает на вход строку символов и преобразовывает её.

Редактор может выполнять две команды, в обеих командах v и w обозначают цепочки символов.

А) заменить (v, w).

Эта команда заменяет в строке первое слева вхождение цепочки v на цепочку w.

Например, выполнение команды

заменить (111, 27)

преобразует строку 05111150 в строку 0527150.

Если в строке нет вхождений цепочки v, то выполнение команды заменить (v, w) не меняет эту строку.

Б) нашлось (v).

Эта команда проверяет, встречается ли цепочка v в строке исполнителя Редактор. Если она встречается, то команда возвращает логическое значение «истина», в противном случае возвращает значение «ложь». Строка исполнителя при этом не изменяется.

Цикл

ПОКА условие

      последовательность команд

КОНЕЦ ПОКА

выполняется, пока условие истинно.

В конструкции

ЕСЛИ условие

      ТО команда1

КОНЕЦ ЕСЛИ

выполняется команда1 (если условие истинно).

В конструкции

ЕСЛИ условие

      ТО команда1

      ИНАЧЕ команда2

КОНЕЦ ЕСЛИ

выполняется команда1 (если условие истинно) или команда2 (если условие ложно).

На вход приведённой ниже программе поступает строка, начинающаяся с символа «>», а затем содержащая 10 цифр 1, 20 цифр 2 и 30 цифр 3, расположенных в произвольном порядке.

Определите сумму числовых значений цифр строки, получившейся в результате выполнения программы.

Так, например, если результат работы программы представлял бы собой строку, состоящую из 50 цифр 4, то верным ответом было бы число 200.

НАЧАЛО

ПОКА нашлось (>1) ИЛИ нашлось (>2) ИЛИ нашлось (>3)

      ЕСЛИ нашлось (>1)

            ТО заменить (>1, 22>)

      КОНЕЦ ЕСЛИ

      ЕСЛИ нашлось (>2)

            ТО заменить (>2, 2>)

      КОНЕЦ ЕСЛИ

      ЕСЛИ нашлось (>3)

            ТО заменить (>3, 1>)

      КОНЕЦ ЕСЛИ

КОНЕЦ ПОКА

КОНЕЦ

Посмотреть ответ. Посмотреть решение.

15. На рисунке представлена схема дорог, связывающих города А, Б, В, Г, Д, Е, Ж, З, И, К, Л, М. По каждой дороге можно двигаться только в одном направлении, указанном стрелкой.

Какова длина самого длинного пути из города А в город М? Длиной пути считать количество дорог, составляющих этот путь.

Посмотреть ответ. Посмотреть решение.

16. Значение арифметического выражения: \mathbf{9^{11}\times 3^{20}-3^{9}-27} – записали в системе счисления с основанием 3. Сколько цифр 2 содержится в этой записи?

Посмотреть ответ. Посмотреть решение.

17. В языке запросов поискового сервера для обозначения логической операции «ИЛИ» используется символ «|», а для обозначения логической операции «И» – символ «&».

В таблице приведены запросы и количество найденных по ним страниц некоторого сегмента сети Интернет.

Запрос Найдено страниц (в сотнях тысяч)
Физика 46
Квант 34
Ньютон 34
Ньютон | Физика | Квант 90
Ньютон & Физика 12
Ньютон & Квант 0

 

Какое количество страниц (в сотнях тысяч) будет найдено по запросу Физика & Квант?

Считается, что все запросы выполнялись практически одновременно, так что набор страниц, содержащих все искомые слова, не изменялся за время выполнения запросов

Посмотреть ответ. Посмотреть решение.

18. Для какого наименьшего целого неотрицательного числа А выражение

(x+2y\textless A)\vee(y \textgreater x)\vee(x\textgreater 20)

тождественно истинно, т.е. принимает значение 1 при любых целых неотрицательных x и y?

Посмотреть ответ. Посмотреть решение.

19. В программе используется одномерный целочисленный массив A с индексами от 0 до 11. Значения элементов массива A[i] приведены в таблице.

i 0 1 2 3 4 5 6 7 8 9 10 11
A[i] 14 13 15 8 4 12 30 21 22 16 5 9

Определите значение переменной s после выполнения следующего фрагмента этой программы (записанного ниже на пяти языках программирования).

Бейсик Python
s = 0
n = 1
FOR i = 0 TO 11
     IF A(i) > A(n) THEN
         s = s + A(i) + i
     ELSE
         A(n) = A(i)
     END IF
NEXT i
s = 0
n = 1 for i in range(0, 12):
     if A[i] > A[n]:
         s += A[i] + i
     else:
         A[n] = A[i]
Алгоритмический язык Паскаль
s := 0
n := 1 
нц для i от 0 до 11
    если A[i] > A[n] то
      s := s + A[i] + i
    иначе
      A[n] := A[i]
    все
кц
s := 0;
n := 1;
 for i := 0 to 11 do
    if A[i] > A[n] then
      s := s + A[i] + i
    else
      A[n] := A[i];
С++
s = 0;
n = 1;
for (int i = 0; i < 12; i++)
{
      if (A[i] > A[n])
         s += A[i] + i;
             else
         A[n] = A[i];
 }

 

Посмотреть ответ. Посмотреть решение.

20. Ниже на пяти языках программирования записан алгоритм. Получив на вход натуральное десятичное число x, этот алгоритм печатает два числа: L и M. Укажите наибольшее число x, при вводе которого алгоритм выводит сначала 2, а потом 3.

Бейсик Python
DIM X, L, M AS INTEGER 
INPUT X 
L = 0 
M = 0 
WHILE X > 0
   M = M + 1
   IF X MOD 2 <> 0 THEN
     L = L + X MOD 8
   END IF
   X = X \ 8 
WEND 
PRINT L 
PRINT M
x = int(input()) 
L = 0 
M = 0 
while x > 0:
     M = M + 1
     if x % 2 !=  0:
         L = L + x % 8
     x = x // 8 
print(L) 
print(M)
Алгоритмический язык Паскаль
алг  
нач
   цел x, L, M
   ввод x
   L := 0
   M := 0
   нц пока x > 0
      M := M + 1
      если mod(x, 2) <> 0
        то
        L := L + mod(x, 8)
      все
      x := div(x, 8)
   кц
   вывод L, нс, M
кон
var x, L, M: integer;
begin
   readln(x);
   L := 0;
   M := 0;
   while x > 0 do
   begin
     M := M + 1;
     if x mod 2 <> 0 then
        L := L + x mod 8;
     x := x div 8
   end;
   writeln(L);
   writeln(M) 
end.
С++
#include <iostream> 
using namespace std; 
 
int main(){
     int x, L, M;
     cin >> x;
     L = 0;
     M = 0;
     while (x > 0) {
         M = M + 1;
         if(x % 2 !=  0) {
             L = L + x % 8;
         }
         x = x / 8;
     }
     cout << L << endl << M << endl;
     return 0; 
}

 

Посмотреть ответ. Посмотреть решение.

21. Определите наибольшее значение входной переменной k, при котором программа выдаёт тот же ответ, что и при входном значении k = 27. Для Вашего удобства программа приведена на пяти языках программирования.

Бейсик Python
DIM K, I AS LONG 
INPUT K 
I = 1 
WHILE F(I) < G(K)
   I = I + 1 
WEND 
PRINT I 
 
FUNCTION F(N)
   F = N * N * N 
END FUNCTION 
 
FUNCTION G(N)
   G = 2 * N + 2 
END FUNCTION
def F(n):
     return n*n*n 
 
def G(n):
     return 2 * n + 2 
 
k = int(input()) 
i = 1 
while F(i) < G(k):
     i+=1 
print (i)
Алгоритмический язык Паскаль
алг
нач
   цел i, k
   ввод k
   i := 1
   нц пока f(i) < g(k)
     i := i + 1
   кц
   вывод i 
кон 
 
алг цел f(цел n) 
нач
   знач := n * n * n 
кон 
 
алг цел g(цел n)
нач
   знач := 2 * n + 2 
кон
var
   k, i : longint; 
 
function F(n: longint): longint; 
begin
   F := n * n * n; 
end; 
 
function G(n: longint): longint; 
begin
   G := 2 * n + 2; 
end; 
 
begin
   readln(k);
   i := 1;
   while F(i) < G(k) do
      i := i + 1;
   writeln(i) 
end.
С++
#include <iostream> 
using namespace std; 
 
long F(long n) {
   return n * n * n; 
}   
long G(long n) {
   return 2 * n + 2; 
} 
 
int main() 
{
   long k, i;
   cin >> k;
   i = 1;
   while(F(i) < G(k))
     i++;
    cout << i;
   return 0; 
}

 

Посмотреть ответ. Посмотреть решение.

22. Исполнитель Вычислитель преобразует число на экране. У исполнителя есть две команды, которым присвоены номера:

1. Прибавить 1

2. Умножить на 2

Первая команда увеличивает число на экране на 1, вторая умножает его на 2. Программа для Вычислителя – это последовательность команд.

Сколько существует программ, для которых при исходном числе 1 результатом является число 21 и при этом траектория вычислений содержит число 10 и не содержит числа 18?

Траектория вычислений программы – это последовательность результатов выполнения всех команд программы. Например, для программы 121 при исходном числе 7 траектория будет состоять из чисел 8, 16, 17.

Посмотреть ответ. Посмотреть решение.

23. Сколько существует различных наборов значений логических переменных x_1,x_2 \dots x_7, y_1,y_2, \dots y_7p которые удовлетворяют всем перечисленным ниже условиям?

x_1\rightarrow y_1 =1

(x_2\rightarrow (x_1 \wedge y_2)) \wedge (y_2 \rightarrow y_1 )=1

(x_3\rightarrow (x_2 \wedge y_3)) \wedge (y_3 \rightarrow y_2 )=1

\dots

(x_7\rightarrow (x_6 \wedge y_7)) \wedge (y_7 \rightarrow y_6 )=1

В ответе не нужно перечислять все различные наборы значений переменных x_1,x_2 \dots x_7, y_1,y_2, \dots y_7p, при которых выполнена данная система равенств. В качестве ответа Вам нужно указать количество таких наборов.

Посмотреть ответ. Посмотреть решение.

24.
Требовалось написать программу, которая получает на вход натуральное число N, не превосходящее 10^9, и выводит число, равное количеству цифр 4 в десятичной записи числа N. Программист написал программу неправильно. Ниже эта написанная им программа для Вашего удобства приведена на пяти языках программирования.

Бейсик Python
DIM N AS LONG
DIM R, d AS INTEGER
INPUT N 
R = 0 
WHILE N > 0
   d = N MOD 10
   IF d <> 4 THEN
     R = R + d
    END IF
   N = N \ 10 
WEND 
PRINT R 
EN
N = int(input()) 
R = 0 
while N > 0:
     d = N % 10 
    if d != 4:
        R = R + d
     N = N // 10 
print(R)
Алгоритмический язык Паскаль
алг 
нач
   цел N, R, d
   ввод N
   R := 0
   нц пока N > 0
     d := mod(N, 10)
     если d <> 4 то
       R := R + d
     все
     N := div(N, 10)
   кц
   вывод R 
кон
var N: longint;
   R, d: integer; 
begin
   readln(N);
   R := 0;
   while N > 0 do begin
     d := N mod 10;
     if d <> 4 then
        R := R + d;
     N := N div 10;
   end;   writeln(R); 
end
С++
#include <iostream> 
using namespace std; 
 
int main() 
{
   long int N;
   int R, d;
   cin >> N;
   R = 0;
   while (N > 0) {
     d = N % 10;
     if (d != 4) {
       R = R + d;
     }
     N = N / 10;
   }
   cout << R << endl;
   return 0; 
}

Последовательно выполните следующее.

1. Напишите, что выведет эта программа при вводе числа 241.

2. Приведите пример входного числа N, при котором приведённая программа, несмотря на ошибки, выдаёт верный ответ.

3. Найдите допущенные программистом ошибки и исправьте их.

Исправление ошибки должно затрагивать только строку, в которой находится ошибка. Для каждой ошибки:

1) выпишите строку, в которой сделана ошибка;

2) укажите, как исправить ошибку, т.е. приведите правильный вариант строки.

Известно, что в тексте программы нужно исправить не более двух строк так, чтобы она стала работать правильно.

Достаточно указать ошибки и способ их исправления для одного языка программирования.

Обратите внимание на то, что требуется найти ошибки в имеющейся программе, а не написать свою, возможно, использующую другой алгоритм решения.

Посмотреть ответ. Посмотреть решение.

25. Дан целочисленный массив из 30 элементов. Элементы массива могут принимать целые значения от 0 до 10 000 включительно. Опишите на одном из языков программирования алгоритм, который находит количество элементов массива, больших 100 и при этом не кратных 4, а затем заменяет каждый такой элемент на число, равное найденному количеству.

Гарантируется, что хотя бы один такой элемент в массиве есть. В качестве результата необходимо вывести изменённый массив, каждый элемент выводится с новой строчки.

Например, для исходного массива из шести элементов:

141

256

92

148

511

4

программа должна вывести следующий массив:

2

256

92

148

2

4

Исходные данные объявлены так, как показано ниже на примерах для пяти языков программирования. Запрещается использовать переменные, не описанные ниже, но разрешается не использовать некоторые из описанных переменных.

Бейсик Python
CONST N AS INTEGER = 30
DIM A (1 TO N) AS LONG 
DIM I AS LONG,
     J AS LONG,
     K AS LONG 
 
FOR I = 1 TO N 
     INPUT A(I)
NEXT I
... 
 
END
# допускается также
# использовать две  
# целочисленные переменные j и k 
a = [] 
n = 30 for i in range(0, n):
     a.append(int(input()))
... 

Алгоритмический язык Паскаль
алг 
нач
     цел N = 30
     целтаб a[1:N]
     цел i, j, k
     нц для i от 1 до N 
        ввод a[i]
     кц
    ... 
кон
const
     N = 30; 
var
     a: array [1..N] of longint;
     i, j, k: longint; 
begin
     for i := 1 to N do
          readln(a[i]);
     ... 
 
end.
С++
#include <iostream>
using namespace std;
const int N = 30; int main() {
     long a[N];
     long i, j, k;
     for (i = 0; i < N; i++)
         cin >>  a[i];
     ... 
    return 0; 
}

В качестве ответа Вам необходимо привести фрагмент программы, который должен находиться на месте многоточия. Вы можете записать решение также на другом языке программирования (укажите название и используемую версию языка программирования, например Free Pascal 2.6). В этом случае Вы должны использовать те же самые исходные данные и переменные, какие были предложены в условии (например, в образце, записанном на Алгоритмическом языке).

Посмотреть ответ. Посмотреть решение.

26. Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежит куча камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может добавить в кучу один или четыре камня либо увеличить количество камней в куче в пять раз. Например, имея кучу из 15 камней, за один ход можно получить кучу из 16, 19 или 75 камней. У каждого игрока, чтобы делать ходы, есть неограниченное количество камней.

Игра завершается в тот момент, когда количество камней в куче становится не менее 63.

Победителем считается игрок, сделавший последний ход, т.е. первым получивший кучу, в которой будет 63 или больше камней.

В начальный момент в куче было S камней; 1 ≤ S ≤ 62.

Будем говорить, что игрок имеет выигрышную стратегию, если он может выиграть при любых ходах противника. Описать стратегию игрока – значит описать, какой ход он должен сделать в любой ситуации, которая ему может встретиться при различной игре противника. В описание выигрышной стратегии не следует включать ходы играющего по этой стратегии игрока, не являющиеся для него безусловно выигрышными, т.е. не являющиеся выигрышными независимо от игры противника.

Выполните следующие задания. Во всех случаях обосновывайте свой ответ.

Задание 1

а) Укажите все такие значения числа S, при которых Петя может выиграть за один ход.

б) Укажите такое значение S, при котором Петя не может выиграть за один ход, но при любом ходе Пети Ваня может выиграть своим первым ходом. Опишите выигрышную стратегию Вани.

Задание 2

Укажите два таких значения S, при которых у Пети есть выигрышная стратегия, причём одновременно выполняются два условия:

– Петя не может выиграть за один ход;

– Петя может выиграть своим вторым ходом независимо от того, как будет ходить Ваня.

Для каждого указанного значения S опишите выигрышную стратегию Пети.

Задание 3

Укажите значение S, при котором одновременно выполняются два условия:

– у Вани есть выигрышная стратегия, позволяющая ему выиграть первым или вторым ходом при любой игре Пети;

– у Вани нет стратегии, которая позволит ему гарантированно выиграть первым ходом.

Для указанного значения S опишите выигрышную стратегию Вани.

Постройте дерево всех партий, возможных при этой выигрышной стратегии Вани (в виде рисунка или таблицы). На рёбрах дерева указывайте, кто делает ход; в узлах – количество камней в куче.

Дерево не должно содержать партии, невозможные при реализации выигрывающим игроком своей выигрышной стратегии. Например, полное дерево игры не является верным ответом на это задание.

Посмотреть ответ. Посмотреть решение.

27.

Дана последовательность N целых положительных чисел. Рассматриваются все пары элементов последовательности, разность которых чётна, и в этих парах, по крайней мере, одно из чисел пары делится на 17. Порядок элементов в паре неважен. Среди всех таких пар нужно найти и вывести пару с максимальной суммой элементов. Если одинаковую максимальную сумму имеет несколько пар, можно вывести любую из них. Если подходящих пар в последовательности нет, нужно вывести два нуля.

Описание входных и выходных данных

В первой строке входных данных задаётся количество чисел N (2 ≤ N ≤ 10 000). В каждой из последующих N строк записано одно натуральное число, не превышающее 10 000.

Пример входных данных:

5

34

12

51

52

51

Пример выходных данных для приведённого выше примера входных данных:

51 51

Пояснение. Из данных пяти чисел можно составить три различные пары, удовлетворяющие условию: (34, 12), (34, 52), (51, 51). Наибольшая сумма получается в паре (51, 51). Эта пара допустима, так как число 51 встречается в исходной последовательности дважды.

Напишите эффективную по времени и памяти программу для решения этой задачи.

Программа считается эффективной по времени, если при увеличении количества исходных чисел N в k раз время работы программы увеличивается не более чем в k раз.

Программа считается эффективной по памяти, если память, необходимая для хранения всех переменных программы, не превышает 1 Кбайт и не увеличивается с ростом N. Максимальная оценка за правильную (не содержащую синтаксических ошибок и дающую правильный ответ при любых допустимых входных данных) программу, эффективную по времени и памяти, – 4 балла.

Максимальная оценка за правильную программу, эффективную только по времени или только по памяти, – 3 балла.

Максимальная оценка за правильную программу, не удовлетворяющую требованиям эффективности, – 2 балла.

Вы можете сдать одну или две программы решения задачи. Если Вы сдадите две программы, каждая из них будет оцениваться независимо от другой, итоговой станет бо́льшая из двух оценок.

Перед текстом программы кратко опишите алгоритм решения. Укажите использованный язык программирования и его версию.

Посмотреть ответ. Посмотреть решение.

Спасибо за то, что пользуйтесь нашими статьями. Информация на странице «Досрочный ЕГЭ 2020 года, Информатика» подготовлена нашими редакторами специально, чтобы помочь вам в освоении предмета и подготовке к экзаменам. Чтобы успешно сдать нужные и поступить в высшее учебное заведение или колледж нужно использовать все инструменты: учеба, контрольные, олимпиады, онлайн-лекции, видеоуроки, сборники заданий. Также вы можете воспользоваться другими статьями из разделов нашего сайта.

Публикация обновлена: 07.06.2023